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Now go to Attributes>Material Settings and click on the color pallette.  Put in these values (red/green/blue) 199/255/255.  Add to custom colors, select that color, and click OK.  Now go to the Maps tab and click set, click Drop.  Close all popups.  Now deselect all and select the vertices at the end of the gun. 
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Now change the color to black or any color you desire, bearing in mind that the more variety of colors you add to the model the more arduous it will become in making a palette, and then go to the Maps tab and drop the current map.

Your final product should look like this:
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:Side View
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:Front view

Now we have to apply a skeleton to the image.  This allows the image to be animated.  Deselect all.  Go to Edit>Skeleton>Build Joints.  You then see a box somewhere on your image.  Click the second box on the Pop up to move the box on your image.  Then click the yellow box and move it (the root Joint) to the middle of your image.  Then click the Build joint button (1st box) and click and drag to where you want the next joint to be.  Follow this Picture and name the joints accordingly.  
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Now close the Joints box and open up the Edit>Hierarchy Joints selection.  Press ctrl+D to Deselect all vertices.  Open up all the joints.  Select Hull and then select all the vertices that you want to be the Hull.  For the Hull, select the main body.
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Be careful not to select anything but the main body.  With Hull selected, click Attach (6th button).  Then deselect all, click Turret, and select the dome and everything inside it.
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Then Click Attach.  Now deselect all and click GunEnd.  Select the end of the Gun and Click attach.
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Now Save your Model and we are done with designing.  If you think that was hard, well this is even harder.  Now for the animation.  Now go to Window>Animator.  This should take you to the animations.  On the toolbars to the right, click insert>Robot
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Search for your model and open it up.  Go to Insert again, but this time insert 5 lights.  The first one with normal settings, and the next 4 with No Shadow.
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Once this is done, Insert ground and change both palettes to Magenta (r255/g0/b255).  
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Click OK.  Now press “a” to bring up the select actor pop up (Edit>Select Actor).  Select Camera.  Now press “K” to bring up the Keyframes window (View>Show Keyframes) if it is not already there.  On the bottom of the screen, a box that covers the whole bottom will pop up.  In that box double click the blue box to position the Camera.  Enter these settings: 17.68/-17.68/12 (X/Y/Z).  
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As you will see, you cannot see the camera any more.  Don’t worry about it.  We will fix it some other time.  Now scroll down until you see “target (camera).”  Double click the position box and enter 0/0/1.  This tells the camera to focus at this spot.  Then scroll until it says robot1.  Double click the positioning box and enter the settings 0/0/1.  This puts the model at the focus of the camera.  Now scroll to the Ground object.  Double click the blue box and enter the settings 0/0/0.  Now scroll to Light1.  Enter the following in the positioning box according to the settings X/Y/Z:

Light1: 0/-1/30

Light2: -15/-2/6,5

Light3: 0/-15/6,5

Light4: 15/-2/6,5

Light5: 0/15/6,5

Now delete all of the target lights by pressing ‘a’ (Edit>Select actor) and select one target light at a time.  Then press the delete button and conform deletion.  Do likewise with all the other targets.

 Now we have positioned the lights, the camera, the ground, and the model.  We have one more step until we get to the fun stuff.  As you look in the top view, the camera and the lights are not visible.  With the zoom tool, click the top view and zoom in by moving the mouse up until you can see the camera and lights.  Zoom in by clicking and moving the mouse up, zoom out by moving the mouse down.  If the objects are still out of view use the pan tool.  Click and drag in all the views to make them look like this:
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The model is pretty small isn’t it?  Using the scale tool, press ‘a’, and select Robot1.  Click the image and enlarge by moving the mouse to get the image to look like this:
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Exit the scale tool and Open up the positioning box for the Robot1.  Enter the settings [0/0/3.97].  Now the image should look like this:
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If it doesn’t, make sure that your model is selected, by pressing ‘a’ and selecting Robot1.  Then just move the model to your liking by using the move tool and clicking on the model on any of the three viewing screens then moving it.  Next set the Animation length to 80 frames by going to Frames>Animation Length.  Now select the Camera actor.  Press anywhere on the positioning row (teal line).  Click yes to split the channel.  Now click on the newly created box and hold your mouse button and move the box to were you want the keyframe to be.  By following the same procedure make the keyframe window look like this:
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The boxes are at Keyframes: 9,10,19,20,29,30,39,40,49,50,59,60,61,69,70,71,72,80

Now scroll down to the Robot1 Keyframe and do the same procedure but with the green line:
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The boxes should be at: 1,5,10,14,19,20,24,29,30,34,39,40,44,49,50,54,59,60,64,69,70,75,80

Now we are ready for the animation part.  Go back up to ‘Camera.’  Double click on the box for frame 10, (3rd box) and put in the following settings: 0/-25/12.  Do the same for frame 19.  Follow these steps and put in the following settings for all of the frames:

On all the keyframe, make sure the tween characteristic is filled in, not Spline Tween.  Spline tween will make the camera zoom in and out randomly between each keyframe.

 X/Y/Z

Frame10,19= 0/-25/12

Frame20,29= -17.68/-17.68/12

Frame30,39= -25/0/12

Frame40,49= -17.68/17.68/12

Frame50,59= 0/25/12

Frame60,69= 17.68/17.68/12

Frame70-80= -25/0/12

Now it’s time for the animation.  Slide the slider on the OpenGL viewer to frame 4.  Select Robot1 by pressing ‘a’ and selecting robot1.  Next press ‘V’ to bring up the robot Hierarchy popup.  If it does not work, make sure that the vertex actor is not selected; select the actor tool then press ‘V’.  Look at the Hierarchy Robot1 popup.  Open up all the Parents.
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You will see that there are seven boxes, all have some kind of motion on them.  They all can be used to move your joint in different directions.  Now select Torret and then click the box with a ‘Z’ on it.  Now click and hold on the outside of the screen and move the mouse according to where you want the torrent to be when it hits frame number 5.  Once you have done it, close the popup.  Now slide the slider back to the 1st frame.  Hold it and slide it slowly to frame ten.  The tank’s torrent should to one side and then back again.  Now do the same steps, but with every frame that has a 4 in the last digit.  The exception to this is fr75, make sure you do that one the same way.  Well, I’m sad to say that our Animation is over (.  Now all we have to do is render it.  Click Render from the toolbar off to the right.  A big popup will then show up
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Under image file format select ‘Animation’.  Type ‘TankFidget’ for the movie name and ‘tank’ for the image name.  You can also specify which directory to place your animation in and your image in.  Since the animation is a tank, select ‘Specified’ under the change preset tool.  Make the size 100 width x 75 length.  Then select ‘A range of frames’ at the bottom of the pop up.  Last step in Animation; render the file as a gif.  Then select Render, and we are done if you just want to animate your unit.  If you want to import your unit into Civilization keep reading we are only half way done.  Skip down to the next page…..

To start the importing tutorial, I want to congratulate you for coming this far.  Now open up PSP (Paint Shop Pro 8), FLICster, and Animation Shop.  Open up your tank in Animation Shop.  Next go to FLICster and open a new document.
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Change the frame size to 100x75
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Change the frame count to 10 Frames.  Change the frame delay to the highest possible and change the Base File Name to TankFidget.  The last step is to change the output Directory to ummmm, well, to the directory you want it to be exported into.  Once this is all done click export and select yes to open up the newly created FXM file.  Now open up PSP and open the new FXM file.  GO to Image>Palette>Save Palette and save it as ‘original.’  
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Make sure you specify the destination of the palette and save it as a [.pal].  Now go back to Animation Shop and copy the first frame.  Paste it as a new image in PSP.  Now go to Image>Decrease Color Depth>Decrease to 256 colors.  Answer OK on all the prompts.  Go to Image>Palette>Edit Palette.  Then highlight the first color as seen in this picture:
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Now draw columns and rows on a separate sheet of paper like below: (if you use graph paper you wouldn’t have to do this.)

   R G B   



R is for red



G is for Green



B is for Blue

Here comes the labor-intensive part.  You have to write the coordinates of each color in those slots.

Ex. 121/255/46

Copy every single non-magenta color(anything close to 255/0/255 is .

Now make a separate sheet labeled ‘shadows-last two rows’

 R  G B


This table is only for the off magenta colors.

Hey, I know this requires a lot of patience, but if I can do it, you can too.

Once you are done copying the palette, edit the palette on the fxm storyboard (the one you just pasted the first slide on).  The empty square immediately following the first 4 rows is where you will begin entering the coordinates of the colors you copied.  Double click on that square and enter the coordinates of the first color you copied.  Work your way to the right until you don’t have enough room.  Continue one row lower to the left.  Now delete all the magenta colors except for the ones in the last row.  Once that is all done skip to the last row.  Make sure that you don’t delete the last two colors; the last is magenta, and the second to last is the border.  On the third to last square enter the copied colors starting from the one you copied on the Shadow Page.  Work your way to the left until you’re out of room, then go up a row and start again at the rightmost square.  Go back up and set the first 4 rows to lime green (a color you don’t use).  Then take the blueish colors, ones by the neck of the tank, copy them, and input them in the 4 rows starting from the first box.  When you are all done, click OK, and save your palette as {Tank.pal}.  Now the easy part comes in.  Close that image and open up the 100x75 frames you saved in FLICster.  Now load the saved palette by going to Image>Palette>Load and select your [Tank.Pal].  Switch to AS (Animation Shop) and copy the first frame.  Go back to PSP and click on the storyboard to select it and press ctrl+E to paste as a selection.  Paste it in the first square.
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Make sure that you don’t jump the border.(  Now go back to AS and copy the 2nd frame.  Go back to PSP and press ctrl+E.  Paste it in the next square.  When you are done with ninth one, paste it again on the tenth frame.  Only do this on the first row.  Now go to AS and copy the next Frame, and paste it in the next row, first box.  Continue in these steps making sure that you don’t cross the border.  Save in between so you don’t loose your work!  Once you are done cutting and pasting, select the selection tool on the toolbar to the left.  Copy a magenta piece and paste it onto the top of the square.  Be careful not to paste it over the border.  Your final image should look similar to this.  Now when you make the other animations, use the same palette you made.*
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Save your work and go back to FLICster.  Go to the export tab and export the animation into the original Directory (just erase the word ‘FLICster’).  Well, after a long Tutorial, we are done.  Congratulations, you just Designed and animated your first Civ unit.  To get the default view, and all the other views, I’ll leave that up to you to do.

EDIT: This is the hard way of making a palette.  I just found a new way, much easier(I praise the creators of this new utility).  It’s called Pedit.  I will have a separate tutorial on how to use Pedit with this same model depending on the demand of it so VOTE.

CREDITS

Thanks to the Morpheus for putting on his tutorial on Openfx

Thanks to the Firaxins

Thanks to Muffins for posting his tutorial on skeletons

Others who I mistakenly left out

Look for my next tutorial, PART 2 coming soon.

Please VOTE in the poll so I can have a better idea on what to clarify, delete, add, and whatnot. 
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